SashXB

From Free Software Directory
Jump to: navigation, search

Reviews: 0 ... further results.

[edit]

SashXB

http://www-124.ibm.com/developerworks/oss/sashxb/
Runtime and environment for writing native JavaScript applications

This is a candidate for deletion: Links broken. No links to page. Homepage not on archive.org. Email to maintainer broken.Poppy-one (talk) 14:32, 28 July 2018 (EDT)

'SashXB' is an application environment that exposes native functionality to JavaScript. It's useful for Web developers with HTML and JS skills who want to write full-featured native applications, and for experienced programmers who need rapid application development. SashXB programs, called "weblications," are installed and uninstalled either locally or from the Web. SashXB also handles recursive dependency checking and a user-customizable security model. Components can be added easily (and installed as simply as a Weblication) to support any desired native OS functionality.

Documentation

User manual available in HTML format from http://www-124.ibm.com/developerworks/oss/sashxb/documentation/base/; Developer's guide available in HTML format from http://www-124.ibm.com/developerworks/oss/sashxb/documentation/weblications/



Download

http://www-124.ibm.com/developerworks/oss/sashxb/download/runtime/sashxb-1.1.tar.gz

version 1.1-2 (stable)
released on 7 August 2003

Decommissioned

Yes

Links broken. No links to page. Homepage not on archive.org. Email to maintainer broken.



VCS Checkout

:pserver:anonymous@anoncvs.gnome.org:/cvs/gnome

Categories





Licensing

License

Verified by

Verified on

Notes

Verified by

Janet Casey

Verified on

22 April 2002




Leaders and contributors

Contact(s)Role
Maintainer


Resources and communication

AudienceResource typeURI
DeveloperVCS Repository Webviewhttp://cvs.gnome.org/lxr/source/SashXB/
SupportE-mailmailto:sashxb-discussion@www-124.ibm.com


Software prerequisites

KindDescription
Required to uselibgdome2-0 (>= 0.7.0); For Red Hat and Red Hat based distros: mozilla-nspr (>= 1.1)
Required to useFor Debian and Debian based distros: libnspr4 (>= 1.1)
Required to usemozilla-browser (>= 1.1)
Required to uselibgdome2 (>= 0.7.0) glibc (>= 2.2.3)
Required to usemozilla = (>=1.1) libxml2

This entry (in part or in whole) was last reviewed on 29 July 2018.



Entry








































Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.3 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the page “GNU Free Documentation License”.

The copyright and license notices on this page only apply to the text on this page. Any software or copyright-licenses or other similar notices described in this text has its own copyright notice and license, which can usually be found in the distribution or license text itself.